TN3270 Service Template

The TN3270 service provides 3270 gateway access to an SNA network via the TN3270 protocol. The attributes reflect the types of 3270 devices, LU Pools, and load information available on the server. LU Pool and Load attributes are the same as for service type cs3270.

  • BIND, DATA, RESPONSES, SCS, SYSREQ
    These keyword attributes describe the TN3270e functions supported by this service. They are present in the service advertisement if the functions they describe are available.
    BIND
    The server supports the SNA bind image function
    DATA
    The non-SNA 3270 data stream is supported by server
    RESPONSES
    The server supports SNA response mode
    SCS
    The server supports SNA 3270 SCS data stream
    SYSREQ
    The SYSREQ keyboard key is supported on server
  • Security = <security>
    This field will contain the security technique supported by the server. The defined values are:
    NONE
    This server has no explicit security technique
    SSLV3
    This server supports Secure Socket Layer Version 3 standard
  • Ciphersuites = <CipherSpec>,
    <CipherSpec>, ...
    <CipherSpec>
    Identifies the cipher specifications supported by this server. The defined values are:
    • NULL_NULL
    • NULL_MD5
    • NULL_SHA
    • RC4_MD5_EXPORT
    • RC4_MD5_US
    • RC4_SHA_US
    • RC2_MD5_EXPORT
    • DES_SHA_EXPORT
    • TRIPLE_DES_SHA_US
  • RFC1576, RFC1646, RFC1647

    The RFC numbers that document features supported by the service. Current RFC's for TN3270 include 1576, 1646, and 1647.