Unable to record or run Web UI tests on Chrome 111 or Edge 112
When Rational® Functional Tester opens Google Chrome 111 or Microsoft Edge 112 to record or play back a Web UI test, the browser opens with a blank page and fails to record or run the test.
Cause
The browser opens with a blank page due to an issue with the driver for the browser.
Resolution 1
Download and install the fix pack provided at Fix Central.
Resolution 2
- Follow these steps in the New Test From Recording
wizard while you record the test by using Google Chrome 111 or Microsoft
Edge 112:
- Select the options as required for the Web UI test in the Recording Session screen.
- Click Next.
The Select Location page is displayed.
- Specify the name and location for the test, and then click
Next.
The Select Client Application page is displayed.
- Select Google Chrome, and then click
Next.
The Recorder Settings dialog is displayed.
- Select the Advanced section to specify the argument to be used when Rational® Functional Tester opens the browser. option in the
- Enter the following argument in the text box:
--remote-allow-origins=*
- Click Finish.
- Follow these steps in the Run Configuration dialog
while you play back the test in Google Chrome 111 or Microsoft Edge 112:
- Select the options as required for the test run in the Run Configuration page.
- Click Next.
The Advanced playback options page is displayed.
- Select the Launch browser with arguments checkbox to specify the argument to be used when Rational® Functional Tester opens the browser.
- Enter the following argument in the text box:
--remote-allow-origins=*
- Click Finish.