Opening the Target Deployment Port Editor

Target Deployment Ports (TDP) are stored as XDP files, which can be viewed and edited with the Target Deployment Port Editor.

Procedure

To open a TDP in the Target Deployment Port Editor:
  1. From the Start menu, click Rational® Test RealTime > Target Deployment Port Editor, or from a shell or command window, type the command: tdpeditor.
  2. Click File > Open
  3. In the targets directory, select an XDP file and click Open.
  4. Save your changes and reload the TDP in Rational® Test RealTime:
    • In Rational® Test RealTime for Eclipse IDE, right-click the project and click Properties > C/C++ Build > Settings > TDP Build, select another TDP and select the updated TDP again. Click OK.
    • In Rational® Test RealTime Studio, restart Rational® Test RealTime Studio, click Project > Configuration, select the TDP, click Remove. Click New, select the updated TDP again and click OK.
To open a TDP from Rational® Test RealTime:
  1. First you must have the Target Deployment Port view displayed in Rational® Test RealTime. To open this view, in the toolbar associated with the Rational® Test RealTime perspective, click Window, and select Show View > Other > Rational® Test RealTime > Target Deployment Port.
  2. The Target Deployment Port view opens and displays the list of all the Target Deployment Ports that are installed in Rational® Test RealTime. Select a Target Deployment Port and click the Open the Target Deployment port editor button to edit the selected Target Deployment port.
    From this view, you can also open the preferences panel and configure the Target Deployment Port search path.