Supported software

You can find the additional software that are supported for IBM® Rational® Performance Tester.

Contents

Application servers

Support for the following application servers is in reference only to the HTTP Response Time Break Down capability:

Supported software

Version

Components

Notes

Desktop

Agent

IBM WebSphere Application Server

9.0

supported

Not applicable

To collect response time breakdown data

8.5.5

supported

Not applicable

8.5

supported

Not applicable

8.0

supported

Not applicable

7.5

supported

Not applicable

IBM WebSphere Liberty

17.0.0.1

supported

Not applicable

16.0.0.2

supported

Not applicable

Oracle/BEA WebLogic Server

12 and future fix packs

supported

Not applicable

10.3 and future fix packs

supported

Not applicable

9 and future fix packs

supported

Not applicable

Business process management

Supported software

Version

Components

Notes

Desktop

Agent

SAP GUI

7.6 and future fix packs

supported

supported

To record and playback tests of SAP applications built with the SAP GUI client

7.5 compilation 2

supported

supported

Development tools

Supported software

Version

Components

Note

Desktop

Agent

eGit

4.10

supported

Not applicable

Eclipse source control

Google Web Toolkit

2.8 and future fix packs

supported

supported

To record and playback http tests that against web applications built with Google Web Toolkit

2.7 and future fix packs

supported

supported

2.6 and future fix packs

supported

supported

2.5 and future fix packs

supported

supported

2.4 and future fix packs

supported

supported

IBM Engineering Test Management

7.0.1

supported

Not applicable

To initiate the test runs from Engineering Test Management

IBM Engineering Workflow Management

7.0.1

supported

Not applicable

To perform integrations with Engineering Workflow Management

IBM Rational® Application Developer for WebSphere Software

9.7.0.2

supported

Not applicable

Eclipse shell sharing

9.7

supported

Not applicable

9.6.1

supported

Not applicable

IBM® Rational® Application Developer for WebSphere Software

9.7

supported

Not applicable

Eclipse shell sharing

9.6.1

supported

Not applicable

IBM Rational® Application Developer for WebSphere Software

9.6.1

supported

Not applicable

Eclipse shell sharing

IBM Rational® ClearCase

8.0.1

supported

Not applicable

Eclipse source control

IBM® Rational® Functional Tester

10.1.2

supported

Not applicable

Eclipse shell sharing and to run WebUI integrations

IBM® Rational® Quality Manager

6.0.6

supported

Not applicable

To initiate the test runs from Rational Quality Manager

IBM Rational Quality Manager

6.0.5

supported

Not applicable

6.0.4

supported

Not applicable

6.0.3

supported

Not applicable

IBM® Rational® Software Architect Designer

9.7.0.2

supported

Not applicable

Eclipse shell sharing

9.7

supported

Not applicable

9.6.1

supported

Not applicable

IBM® Rational® Software Architect Designer for WebSphere Software

9.7

supported

Not applicable

Eclipse shell sharing

IBM Rational® Team Concert

6.0.6

supported

Not applicable

To perform integrations with Rational Team Concert

6.0.5

supported

Not applicable

6.0.4

supported

Not applicable

6.0.3

supported

Not applicable

Rational® Test Workbench

10.1.2

supported

Not applicable

To integrate and run Rational® Integration Tester tests

JMeter

5.1

supported

Not applicable

To integrate and run JMeter tests

5.2

supported

Not applicable

5.3

supported

Not applicable

DevOps tools

Supported software

Version

Components

Notes

Desktop

Agent

Apache Ant

1.9 or later

supported

Not applicable

To initiate the test runs from ANT

Azure DevOps

Latest release

supported

Not applicable

To initiate the test runs from Azure DevOps pipeline

IBM® UrbanCode Deploy

7.0.2

supported

Not applicable

To initiate the test runs from UrbanCode Deploy

Jenkins

2.235.1

supported

Not applicable

To initiate the test runs from Jenkins

Maven

3.5 or later

supported

Not applicable

To initiate the test runs from Maven

Microfocus ALM

12.6

supported

Not applicable

To initiate the test runs from Microfocus ALM

Message Oriented Middleware

Supported software

Version

Components

Desktop

Agent

IBM® MQ

9.0.0

supported

supported